VDA's do not register with XenDesktop controllers when there is NAT in place between VDA and DDC

VDA's do not register with XenDesktop controllers when there is NAT in place between VDA and DDC

book

Article ID: CTX215734

calendar_today

Updated On:

Description

- There is NAT in place between VDA and DDC's

RegistrationManager.AttemptRegistrationWithSingleDdc: Failed to register with http://DDC.domainname/Citrix/CdsController/IRegistrar. WCF Fault with detail Fail worker callback using SPN HOST/VDA.domainname and IP address <>, message 'Fail worker callback using SPN HOST/VDA.domainname and IP address <>' 

FindAttributesForComputerSid exit: SID=S-1-5-21-4084703721-986140599-3389830516-41493, DNS=c-testcu-d-a02.hosting.local, SAM=C-TESTCU-D-A02$ 
SetWorkerHostUriSpn: ipAddress:10.175.0.227, workerAddress:c-testcu-d-a02.hosting.local, workerSpn:HOST/c-testcu-d-a02.hosting.local 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

From message 'Fail worker callback using SPN HOST/VDA and IP address <>  we can see that DDC does not have correct IP address of VDA. 

Create the below registry key under "HKLM\Software\Citrix\DesktopServer" on all the XenDesktop Controllers in the site and reboot the controllers.
Name: "UseIPAddressFromWcf"
Type: REG_DWORD

By default the above key is set to true and is meant to extract the IP address from WCF, set the key to "0" which means we let the controllers fetch the IP address of the VDA via DNS/WINS.


 

Problem Cause

Broker fetches incorrect IP address of VDA from WCF rather than the actual IP address of VDA

Additional Information

http://support.citrix.com/article/CTX138738