Timeout Settings on Session Profiles Do Not Apply to ICA Sessions In NetScaler

Timeout Settings on Session Profiles Do Not Apply to ICA Sessions In NetScaler

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Article ID: CTX215671

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Updated On:

Description

When setting idle timeout, session timeout, or forced timeout at the session profile of NetScaler Gateway, ICA sessions do not apply.

Resolution

For NS Gateway 10.1 10.5 Platform:

ICA timeouts must be applied at the XenApp level as the actual app launch does not use the same connection as the app enumeration. See CTX127318 - How to Configure Idle and Disconnect Timeout Settings in XenApp for additional information on this.

For NS Gateway 11.0 ,11.1, 12.0 Platform:

Refer below KB to CTX218008 - How to configure ICA Proxy Connection Termination upon AAA Session Time Out.


Problem Cause

ICA sessions are launched after enumeration, and make a separate connection to the NetScaler.  When the client makes a connection to the Gateway for application launch, the session policies are not read.

The timeout values in session policies apply to the StoreFront or Web Interface connection, and VPN and CVPN connections, where the initial client connection to the Gateway which the session profile applies to will be maintained.
 

Issue/Introduction

When setting idle timeout, session timeout, or forced timeout at the session profile of Netscaler Gateway, ICA sessions do not apply.

Additional Information

Citrix Documentation - What's New.