XenDesktop 7.x "ServiceNotinSiteDB" error after site upgrade

XenDesktop 7.x "ServiceNotinSiteDB" error after site upgrade

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Article ID: CTX215625

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Updated On:

Description

After upgrading the Xendesktop 7.x Site database you encounter ServiceNotinSiteDB error
 

Environment

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Resolution

Note: Before we begin take a backup of the Xendesktop Site,Monitor,logging database

Steps to Resolve this issue:


1. Find out the FMA service which is not present in site DB.
2. Find out the controller for which the FMA service is missing.
3. Run the StoredProcedure to add the missing FMA Service.
4. Reboot the controller for which the service was added.
5. Register the service instance of the missing service with the configuration service.
6. Reset the Group membership of the missing service with the configuration service.
7. Check the status of the missing service.

Detailed Explanation:

1. Find out the service which is not present in site DB.


- Get-command Get*servicestatus
- Execute all the commands to check the service status for all the FMA services
- Make note of the FMA service which returns value "ServiceNotinSiteDB"

2. Find out the controller for which the service is missing.

- Run the commands listed in step 1 on all the controllers to find out the missing FMA service on various controllers.
- Make note of all the controllers and the FMA service missing on each controller

3. Run the StoredProcedure to add the missing Service.

- Before running the StoredProcedure we need to find out various parameters that will be given as input on the StoreProcedure..
- Pick any FMA service which returned the value "ok" while checking the service status. (For instance: Analytics service)
- Go on SQL Server hosting the XenDesktop site database 
- Expand XenDesktop database -> right click on Analytics.services table -> click on select 1000 rows
- Save the output on a txt or csv file

- Now expand the Programmability node on the XenDesktop database -> expand Stored Procedures -> right click on the Stored procedure to add the missing FMA service -> for instance: AppLibraraySchema.AddService -> Right click and execute the Stored Procedure

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- Open the txt or csv file that we saved and enter the values for the Controller missing the service.
- All the values should be entered in double quotes.
- Click on OK

4. Reboot the controller for which the service was added.

5. Register the service instance of the missing service with the configuration service.

- Login to the controller using XenDesktop Site admin and open powershell
- Import Citrix snapins using asnp Citrix*
- Register the missing FMA service instance with the configuration service
- For instance: Get-AppLibServiceInstance | Register-ConfigServiceInstance

6. Reset the Group membership of the missing service with the configuration service.

- Reset the group membership of that service using the below command for the missing FMA service
- For Instance: Get-configregisteredserviceinstance -servicetype config | Reset-AppLibServiceGroupMembership

7. Check the status of the missing service.

- Check the service status of the missing FMA service using the below command:
- For Instance: Get-applibservicestatus

Follow the same procedure for all the missing services on all the controllers.
 

Problem Cause

This happens if the service for a particular service for a particular controller has not been entered correctly in the database while the site was upgraded.

Additional Information

http://support.citrix.com/article/CTX212941