Creating a New Site After Receiving Error: There Was a Problem Communicating with the Citrix Delegated Administration Service

Creating a New Site After Receiving Error: There Was a Problem Communicating with the Citrix Delegated Administration Service

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Article ID: CTX215560

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Description

Situations may arise where admins are unable to gain access to manage their site via Studio nor through PowerShell due to the error: 

"There was a problem communicating with the Citrix Delegated Administration service."

In some cases, it may not be possible to recover the site because the database has conflicting information that cannot be manually repaired.
It can then become a challenge to create a new site because Studio will not open properly and  PowerShell will not allow you to make any changes to the site database.
In this case, there are methods by which you can create a new site without uninstalling and reinstalling the controller software.

The steps below define how to nullify the database connection via the registry allowing the admin to open Studio in a First Run scenario and create a brand new site database.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

1. Stop the Citrix Services. Open elevated PowerShell and run:

    Get-Service Citrix* | Stop-Service -force

2. Remove the connection strings value manually via registry on all DDCs in the site:

Connection String in XenApp / XenDesktop 7.6
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\DesktopServer\DataStore\Connections\Controller
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\ADIdentitySchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\Analytics\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\ConfigLoggingSiteSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\ConfigurationSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\DAS\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\DesktopUpdateManagerSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\EnvTestServiceSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\HostingUnitServiceSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\Monitor\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\StorefrontSchema\DataStore\Connections

Connection String in XenApp / XenDesktop 7.15
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\DesktopServer\DataStore\Connections\Controller
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\ADIdentitySchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\Analytics\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\AppLibrarySchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\ConfigLoggingSiteSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\ConfigurationSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\DAS\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\DesktopUpdateManagerSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\EnvTestServiceSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\HostingUnitServiceSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\Monitor\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\OrchestrationSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\StorefrontSchema\DataStore\Connections
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\XDservices\TrustSchema\DataStore\Connections​


Example

Delete the value for the ConnectionString Registry Key:

User-added image
3. Restart the Citrix Services. Open elevated PowerShell and run:
    Get-Service Citrix* | Start-Service

4. Open Studio. You will see the option to create a new site. Follow the wizard to create a new database for your site.

5. Once completed, add any additional DDC(s) as needed.
 

Problem Cause

This can happen for a number of reasons, but mainly because XenDesktop best practices (see link below) were not followed during site configuration and maintenance.

For example:
- the XenDesktop / XenApp admin account was deleted from AD then re-added, changing the SID of the admin user account.
- the DDC's were rejoined to the Domain hence changing the SID of the machines.

Issue/Introduction

This article helps in a scenario where a customer cannot gain access to their site and keep getting the dreaded Delegated Administration Service does not have proper permissions. This will assist in removing your DDCs from the site and creating a new site.

Additional Information


CTX139331 - Citrix Virtual Desktop Handbook 7.x

CTX132799 - XenDesktop and XenApp Best Practices - (For older deployments, but still mostly applicable to newer releases)