Allow access to Secure Hub.apk file for Samsung Knox enrollment

Allow access to Secure Hub.apk file for Samsung Knox enrollment

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Article ID: CTX215500

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Updated On:

Description

Entering the path to the Secure Hub.apk file is not working when trying to enroll in Samsung Knox

Resolution

As per Samsung documentation, you will need to whitelist the sites below.

All Devices
https://gslb.secb2b.com*
443
Global Load Balancer for MEP initiation

All Devices
http://gslb.secb2b.com*
80
Global Load Balancer for MEP initiation on some limited Legacy Devices

All Devices
umc-cdn.secb2b.com*
443
Samsung Agent Update servers

All Devices
bulkenrollment.s3.amazonaws.com* eula.secb2b.com*
80, 443
MEP Customer EULAs

All Devices
us-be-api-mssl.samsungknox.com
443
Samsung servers for IMEI Verification

Additional configurations need to be in place for Global End points and are listed below    

US    
https://us-segd-api.secb2b.com*
443

EU Devices    
https://eu-segd-api.secb2b.com*
443

China Devices    
https://china-segd-api.secb2b.com.cn*
443

Problem Cause

Samsung requires specific sites to be whitelisted on a clients Firewall.

https://www.samsungknox.com/en/qa/our-corporate-devices-are-behind-firewall-how-do-i-enable-knox-devices-contact-samsung-servers