WeChat login window is surrounded by a blue border in XenApp session
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Article ID: CTX215340
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Updated On:
Description
WeChat is a popular IM software in China. In use case of publishing WeChat as a XenApp seamless application, customer might found WeChat login window is is surrounded by a border filled with blue Windows Desktop wallpaper.

Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Create below key and registry in XenApp server, logoff user session and re-launch WebChat application.
- Goto "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI", create a key named "popupshadow".
- Under "popupshadow", create below two registry values
- ClassName (REG_SZ) = popupshadow
- Type (REG_DWORD) = 1000 (Hex)
Problem Cause
In WebChat user login GUI, there is a
WS_EX_transparent styled window with ClassName=popupshadow. So the window is invisible in a physical machine. In XenApp seamless session, when Citrix seamless engine creating such a
WS_EX_transparent styled window at client side, the default behavior is to fill the window with background image, like Windows desktop wallpaper, rather than display it as transparent effect.
Issue/Introduction
The article describes a 3rd-party application display issue in XenApp seamless.
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