black screen when launch ICA session after installing some scanner driver

black screen when launch ICA session after installing some scanner driver

book

Article ID: CTX215168

calendar_today

Updated On:

Description

Black screen when launch ICA session after installing some scanner driver (e.g. kodak i2400). After login from console, an error shows Dwm.exe crashes.
User-added image

Resolution

Replace the picn20.dll from system32 and replace with the file from %ROOT%\Program Files\Citrix\ICAService.

Problem Cause

When install the driver, PICN20.dll was added to C:\Windows\System32 directory.
Citrix also uses a newer version of this file located under %ROOT%\Program Files\Citrix\ICAService.