Published desktop disconnects when a published application is launched from within the desktop session using the same store.

Published desktop disconnects when a published application is launched from within the desktop session using the same store.

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Article ID: CTX215150

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Description

Scenario :

1. A single store is configured to launch published applications and desktops.
2. A published desktop is launched : This is a Windows Desktop session.
3. From this session , a published application is launched.
4. As soon as we launch the published application , the published desktop session disconnects.

Resolution

Note : This is expected behavior and can be changed by implementing one of the solutions mentioned :

Solution 1:
 

Modify the following key from the default value of 3 to zero

64-Bit - [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Dazzle]
32-Bit - [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Dazzle]
Name:  WSCReconnectMode
Type: REG_SZ
Value data: 0

Solution 2 :

Modify or create the following key from the default value of True to False 

1. HKCU \Software\Citrix\Dazzle
2. HKCU \Software\Citrix\Receiver\SR\Store\+ primaryStoreID + \Properties
3. HKLM\SOFTWARE\Policies\Citrix\Dazzle
4. HKLM\SOFTWARE\Citrix\Dazzle


Name : WSCReconnectAll
Type : REG_SZ
Value Data : False

Solution 3:

Create a new store for the application delivery group so that the default behavior does not kick in seeing the different stores. 

Problem Cause

When an application is launched within a published desktop it is seen as an open application which generates a disconnection.

Additional Information

http://support.citrix.com/article/CTX136339