Application Enumeration Fails When Using Receiver with Unified Gateway
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Article ID: CTX215087
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Updated On:
Description
This article is intended for Citrix administrators and technical teams only.
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.
When using Unified Gateway, Receiver users are unable to enumerate applications, and receive a message that there are no applications available. A content switch is used with Unified Gateway.
Using a web browser, enumeration is working as expected. Connnection through Receiver has the issue. Bypassing NetScaler Gateway also resolves the issue. The store is requested by the user, but an error that there are no apps available appears afterwards. Using a Gateway VIP enumeration is good as well.
Resolution
Check the content switch policy on the Gateway. Most likely it will be similar to the following:
"is_vpn_url || HTTP.REQ.URL.PATH.SET_TEXT_MODE(IGNORECASE).STARTSWITH(\"/Citrix/StoreWeb\")"
If so, modify the policy to remove the StoreWeb portion of the expression. The expression should be only /Citrix:
"is_vpn_url || HTTP.REQ.URL.PATH.SET_TEXT_MODE(IGNORECASE).STARTSWITH(\"/Citrix/\")"
Problem Cause
The /StoreWeb portion of the expression interferes with many aspects of app enumeration, as many links begin with /Citrix but do not include the actual store name in the rest of the URL.
Issue/Introduction
When using Unified Gateway, Receiver users are unable to enumerate applications, and receive a message that there are no applications available.
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