Accessing NetScaler Gateway VIP Shows a Blank White Screen

Accessing NetScaler Gateway VIP Shows a Blank White Screen

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Article ID: CTX214932

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Updated On:

Description

Even after creating a brand new NetScaler Gateway VIP, accessing the VIP shows a blank white screen. The forwarding to /vpn/index.html does show in the URL. Issue occurs before authentication and SSL certificate is valid and bound correctly.
 
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Another NetScaler in the HA pair doesn’t experience the issue. Comparing the /netscaler/ns_gui/vpn directory shows the files are different.

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Resolution

Solution: 1


Copy the /netscaler/ns_gui/ directory from one NetScaler to another using the following instructions [assuming on 10.1.1.1 (working) and 10.2.2.2 (corrupt)]:

root@10.1.1.1# cd /netscaler/ns_gui/
root@10.1.1.1# tar -cvzf /var/netscaler/nsgui.tgz ./ns_gui/*
root@10.1.1.1# scp /var/netscaler/nsgui.tgz nsroot@10.2.2.2:/var/netscaler/

root@10.2.2.2# cd /netscaler/
root@10.2.2.2# rm -R ns_gui/
root@10.2.2.2# mkdir ns_gui
root@10.2.2.2# tar -xvzf /var/netscaler/nsgui.tgz

 

Solution: 2


Perform a clean install of from 11.1 to NetScaler version 12.1.
After the build, create a custom theme based on X1 and then copy the theme files on top of the resolved issue.


Problem Cause

Customizing the logon page and the default files at /netscaler/ns_gui/ was missing, modified, or corrupted.

Issue/Introduction

Accessing the NetScaler Gateway VIP shows a blank white screen.