Local Profiles fail to delete or Applications may fail to load because of locked files or folders on server running UPM 5.4.1

Local Profiles fail to delete or Applications may fail to load because of locked files or folders on server running UPM 5.4.1

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Article ID: CTX214731

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Updated On:

Description

When logging off, Profile management (UPM) occasionally locks files/folders on the server, causing applications to fail to launch. Locally cached profiles also do not get deleted.

Resolution

A code change to address this behaviour has been included in Profile Management 5.4.1 (tracked as LC5266 in the Fixed Issues).
As newer versions of Profile Management contain the code changes of previous releases, this code change is included in Profile Management 5.x versions after UPM 5.4.1. 


Problem Cause

An issue with the cache filling of files inadvertently caused file handles to remain open on certain files or folders. 
This prevented these files and, as a result, the profile from being successfully deleted. 

This leaves the file handle open by Profile Management.

Issue/Introduction

When logging off, Profile management occasionally locks files/folders on the server, causing applications to fail to launch. Locally cached profiles also do not get deleted.

Additional Information

In a UPM log or a CDF Trace, this issue shows as a message similar to the following: 
CJitFolderSupport::CacheFillFile: request for <AppData\Roaming\Microsoft\Windows\Cookies\138W5MW7.txt> failed with error 0x56: The specified network password is not correct.
Failed to cache-fill file, error 86