Fujitsu Scanner USB Redirection Not Working Windows 2012 R2

Fujitsu Scanner USB Redirection Not Working Windows 2012 R2

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Article ID: CTX214725

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Description

- Fujitsu scanner looks to be redirected successfully. We can see the device inside our ICA session and is listed in device manager without any obvious problems.
- Functionality however is lost and scanner does not work as expected despite confirming that the correct drivers are in place.

Resolution

- This is a known shortcoming with certain device drivers that are not designed to operate inside a multi session environment e.g. Windows Server 2012 R2
- To confirm that above you should attempt to redirect the same device into a single session VDA e.g. Windows 7. Here we would expect to see the device work as expected
- One additional test to confirm the issue lies outside of any Citrix components is to attempt to redirect the Device using Microsoft RemoteFX. This is essentially the same technology used with Citrix Generic USB Redirection. To confirm that the issue is driver specific we would expect to see the same behavior when redirecting over RemoteFX.
 

Problem Cause

- There are historically multiple challenges exposed by RDSH platforms e.g. Windows Server 2012 R2
- With generic USB redirection the USB client drivers are installed on the host so these drivers must be compatible with RDSH for Windows 2012R2
- Certain kind of devices pose challenges when redirected to a XenApop session and there are certain devices that are prohibited for performance reasons
- The devices that will not work out of the box in XA 7.6 environment are as follows:
  --> USB Storage Devices
 --> Audio Devices
 --> Smartcard Readers
 --> other devices which are not fully virtualizes and by this we mean devices that are managed by a dedicated service running in Session 0

In this case the scanner was managed by the WIA service (session 0) and consequently does not work despite the fact that the device was redirected successfully and could be seen inside the session with no issues.
We can confirm that the same device works successfully inside a Windows 7/8 desktop session this is because it is a single session environment.
The device driver does not appear to have the capability of handling multiple instances of the same device presented from different XenApp sessions.
This is confirmed by using the device when physically plugged into the server and when logged into session 1 on the machine

This looks to be a shortcoming with some device drivers and as a result, a resolution will require a new device driver that has been designed to work inside a multi session environment.

We currently have open channels of communication on this with the device manufacturer Fujistu.
There are also a number of feature enhancements logged that centre around the same issue (7165, 7144)

Issue/Introduction

Fujitsu Scanner not functioning inside VDA Session. Fujitsu scanner looks to be redirected successfully i.e. we can see the device inside our ICA session and is listed in device manager without any obvious problems

Additional Information

http://blogs.citrix.com/2014/11/13/generic-usb-redirection-in-xenapp-7-6/