Error: "No Image Preparation results found" during MCS catalog creation with Citrix UPM installed Master Image

Error: "No Image Preparation results found" during MCS catalog creation with Citrix UPM installed Master Image

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Article ID: CTX214572

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Updated On:

Description

MCS Machine Catalog creation/update fails with the error "No Image Preparation results found"

Exception:
Citrix.Console.Models.Exceptions.ScriptException Preparation of the Master VM Image failed. Make sure the selected image has a supported OS (for example, Windows 7) and the correct version of the VDA (7.0 or later) installed. at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.WaitForProvisioningSchemeActionCompletion(Guid taskId, Action`1 actionResultsObtained) at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeCreationTask.StartProvisioningAction() at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeCreationTask.RunTask() at Citrix.Console.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run() DesktopStudio_ErrorId : UnknownError ErrorCategory : NotSpecified ErrorID : ImagePreparationFinalizationFailedCompletely TaskErrorInformation : Terminated InternalErrorMessage : No Image Preparation results found, suggesting no suitable VDA or other serious failure in the Master VM. Image preparation failed.

In Studio Logging we get this error:
Making consolidated copy of Image Name:/xxxxxxxxxx/xxxxxxxxxxxx.cluster/xxxxxxxx.vm/Citrix_XD_Test.snapshot/Citrix_XD_testoc.snapshot, HostingUnit Name:xxxxxxxxxx.
 

Resolution

This problem happens because the C:\program files\Citrix\PvsVM\Service\PersistedData is not empty and has UPM logs stored.

Following two steps resolved the problem:

1. Blocked the UPM log location policy from applying to Master Image
2. Reinstall the VDA using the Master image option

Detailed explanation:

During Image preparation, on the Preparation VM the results of MCS preparation are stored in the Identity Disk in a file named PreparationStatus.xml. This file is read by MCS to confirm that the Image Preparation completed. But the file is not directly written to the Identity disk. Instead C:\program files\Citrix\PvsVM\Service\PersistedData is mapped as a reparse point to the folder on Identity disk and writing PreparationStatus.xml file in to C:\program files\Citrix\PvsVM\Service\PersistedData will actually write the file to the Identity disk. In this specific case the creation of reparse point failed because the C:\program files\Citrix\PvsVM\Service\PersistedData was not empty and contained UPM Config and log files. By default on a master image this folder will be empty. Customer had a UPM policy configured as per http://docs.citrix.com/en-us/profile-management/5/upm-troubleshoot-wrapper-den/upm-enable-logging.html which recommends storing the UPM logs to C:\program files\Citrix\PvsVM\Service\PersistedData folder. However this is only applicable for MCS created machines and not applicable for Master images. Clearing up the folder and then blocking the policy from applying to Master image helped to remove the UPM related files from this folder. However there was another folder named BrokerInfo present. This folder is supposed to be present under C:\ProgramData\Citrix\PvsVMAgent\LocallyPersistedData on a master image. On the other hand on a MCS created machine, this folder will be present under C:\program files\Citrix\PvsVM\Service\PersistedData folder. So it was clear that the machine used as master was actually a clone of a machine created by MCS and not a proper master image. Reinstalling the VDA using the appropriate option resolved the problem. Subsequently creation of MCS machines using this master succeeded without any error.

Problem Cause

There were multiple causes in this specific case:

1. MCS created machine's clone was being used as Master image
2. UPM policy was configured to store logs under C:\Program Files\Citrix\PvsVM\Service\PersistedData and this policy was applied to the Master image.

Issue/Introduction

MCS Machine Catalog creation/update fails with the error "No Image Preparation results found" when using a Master image that has Citrix UPM Installed and the UPM logs are stored under C:\program files\Citrix\PvsVM\Service\PersistedData folder.

Additional Information

There can be other reasons for this error message. Please refer to CTX202656 for generic troubleshooting guidelines for this error.