Discovery not running with error "Object reference not set to an instance of an object."
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Article ID: CTX214324
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Updated On:
Description
Unable to run Discovery from any of the Zone Data Collector Servers and getting error as "Object reference not set to an instance of an object."
The IMA Service on the specified Server for Discovery might crash when we attempt to run the discovery.
After investigation, we could see multiple duplicate entries for certain servers in the dscheck command :

Resolution
Run "dscheck /full servers /clean" to clean the duplicate server entries and recreate Local Host Cache on the Zone Data Collector Servers and all member servers.
NOTE: Make sure we have Xenapp Database backup before running any "DSCHECK" Commands.
Problem Cause
Inconsistent duplicate server entries in Xenapp Database lead to this issue.
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