Target Device hangs at Black screen or Windows Logo indefinitely

Target Device hangs at Black screen or Windows Logo indefinitely

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Article ID: CTX214247

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Updated On:

Description

During the early stages of a Target Device boot process, it hangs indefinitely at a Black Screen or just before showing the Windows Logo.
Depending on how many Target Devices are booting at a time, the affected Target might finally finish booting after 30 to 60 minutes.
In some cases the Target Device never finishes the complete the boot process and does not reach the Windows login screen at all.
Monitoring the Target Device on the Hypervisor shows that the Target Device might be consuming an excessive amount of CPU.

Note: If the Target has already reached the Windows login screen, then it has gotten past this issue and this article will most probably not apply.

Resolution

Confirm that "Interrupt Safe Mode" is not enabled in the bootstrap or BOOT.ISO configuration.

For more information about "Interrupt Safe Mode" and how to disable it, please refer to the following article: How to disable Interrupt Safe Mode in Provisioning Services

 

Problem Cause

"Interrupt Safe Mode" was configured in the bootstrap settings or while creating a BOOT.ISO

The "Interrupt Safe Mode" configuration is a special setting designed to handle bad PXE implementations that do not comply with PXE standards or have bugs.
The setting forces a reset on the UNDI Interface after sending every packet into the Network. This causes a considerable delay in communications and it's only meant to cope with buggy PXE implementations.
Note: The PXE implementation itself is not a PVS component. The PXE code resides in the Hypervisor or Physical NIC Firmware.