Unable to send emails with attachment with error "Can't Send Mail. Your message has been moved to the outbox..."
book
Article ID: CTX213580
calendar_today
Updated On:
Description
Users are unable to attach files to their emails. It fails with the following error:
Error: "Can't Send Mail. Your message has been moved to the outbox. Please go to the outbox and try again."
Resolution
Configure the "uploadReadAheadSize" attribute on the Exchange server to a minimum of 204800 KB by doing the following steps:
- Open the command prompt
- Change directories to the C:\Windows\SysWOW64\inetsrv: CD C:\Windows\SysWOW64\inetsrv
- Determine the current metabase property value: appcmd.exe list config –section:system.webServer/serverRuntime
- Increase the metabase property value: appcmd.exe set config -section:system.webServer/serverRuntime /uploadReadAheadSize:"204800" /commit:apphost
Problem Cause
The configured limits for the "uploadReadAheadSize" attribute is exceeding the maximum bytes allowed in the entity body of a request.
Additional Information
The UploadReadAheadSize property establishes the number of bytes a Web server will read into a buffer and pass to an ISAPI extension. This occurs once per client request. The ISAPI extension receives any additional data directly from the client. The range is 0 to &HFFFFFFFF (4 GB).
https://www.iis.net/configreference/system.webserver/serverruntime
Was this article helpful?
thumb_up
Yes
thumb_down
No