iOS And Android Users Prompted For Authentication Twice While Adding Account

iOS And Android Users Prompted For Authentication Twice While Adding Account

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Article ID: CTX213544

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Updated On:

Description

iOS/Android users are being prompted for authentication twice while adding the account. Customers had issue with adding the account on iOS and Android when StoreFront was configured as HTTPs. After changing it to HTTP they were able to add account but users were being prompted for authentication twice by Receiver. As per our analysis The Dual Prompt is because the Receiver is not sending the NetScaler Cookie which seems to have triggered due to a redirect.

Resolution

Corrected gateway name to https://FQDN.

Problem Cause

Incorrect Gateway name: https://FQDN/
Changed to https://FQDN.

Issue/Introduction

iOS/Android users are being prompted for authentication twice while adding the account. Customers had issue with adding the account on iOS and Android when StoreFront was configured as HTTPs.