There are no licenses installed on the license server. Install a valid license, then try again

There are no licenses installed on the license server. Install a valid license, then try again

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Article ID: CTX213448

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Updated On:

Description

After first controller is upgraded and pointed the license server, the error - Citrix.Console.Models.Exceptions.ScriptException There are no licenses installed on the license server. Install a valid license, then try again

We get this below error on Studio, while opening the License Tab 

Error Id: XDDS:FD518EF7 

Exception: 
Citrix.Console.Models.Exceptions.ScriptException . 
at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host) 
at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover) 
at Citrix.Console.PowerShellSdk.LicensingService.Scripts.GetLicenseUsageScript.RunScript() 
at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run() 
at Citrix.Console.PowerShellSdk.LicensingService.PSLicenseService.GetLicenseInventory(String adminAddress) 
at Citrix.Console.Licensing.UI.Mmc.LicensingTabViewModel.<>c__DisplayClass8.<OnRefresh>b__3() 
at Citrix.Console.CommonControls.ViewModelBase.<>c__DisplayClasse.<RunBackgroundTask>b__c(Object s, DoWorkEventArgs e) 

DesktopStudio_ErrorId : NoInventory 
Sdk Error Message : NoInventory 
Sdk Error ID : Citrix.PowerShell.LicensingAdminStatus.NoInventory,Citrix.Licensing.Admin.SDK.Commands.GetLicInventoryCommand 
ErrorCategory : NotSpecified 
DesktopStudio_PowerShellHistory : GetLicenseUsageScript 

Resolution

Verify there is no stale entry of the old license server:

  1. Verify if  older version license server installer trace present and citrix licensing service & Citrix Licensing Support Service were not removed, manually remove the services using sc delete command and delete the corresponding registry entry 
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Citrix Licensing 
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Citrix_GTLicensingProv 
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\CitrixWebServicesforLicensing 
    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{GUID} 
  2. Search for C:\Program Files (x86)\Citrix\Licensing\MyFiles & C:\Program Files (x86)\Citrix\Licensing path in registry and delete corresponding entry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components 
  3. Delete C:\Program Files (x86)\Citrix\ folder in file system (c:) 
  4. Reboot the server  
  5. Upon relogin to the server make sure all citrix license related service is removed in services.msc and citrix license related entry is removed in registry 
  6. Install Citrix License server 11.13.1.2 Build 16002 from XenDesktop 7.8 iso 
  7. Re-configure both the XD 7.8 site to the new license server


Solution 2: Install fresh license Server and configure and point it in Studio


Problem Cause

Stale entries of old license server