XenDesktop 7.8 and 7.9 - System Hangs on Telemetry Service

XenDesktop 7.8 and 7.9 - System Hangs on Telemetry Service

book

Article ID: CTX212998

calendar_today

Updated On:

Description

Customers report provisioned targets device running VDA 7.8, hang after system boot on screen "please wait" or "getting devices ready"

VDA 7.8 or 7.9 is booted and hangs at one of below reported screens at console, never progressing further: 
"Please wait" spinning wheel, "Please wait while configuring new hardware" spinning wheel, "Please wait on loading user profile" just after user login 
Never progress beyond this screen.
 

Resolution

Recommend configurations to resolve behaviour:
-Set the "Telemetry Service" to "Automatic Delayed Start" or "Disabled".
OR
-Remove Microsoft policy "Computer configuration\Policies\System\User Profiles\Delete user profiles older than (days)".

Problem Cause

Appears to be a Microsoft bug, and potentially reproducible outside of using telemetry service.
Microsoft policy below to remove old user profile folders and files, creates an operating system hang at start up, if the user profile for service virtual account qualifies for deletion and the service is set to automatic start up. 
Policy: 
"Computer Configuration\Administrative Templates\System\User Profiles\Delete user profile older than a specified number of days on a system restart" 

VDA 7.8 and 7.9 have the telemetry service, which uses a windows virtual account. 
(Every service since windows vista has a virtual account, whether it is used or not). 
Part of using service virtual account is that at service start up, folders and files are populated in user account directory for that virtual account. 
 

Issue/Introduction

"Please wait" spinning wheel, "Please wait while configuring new hardware" spinning wheel, "Please wait on loading user profile" just after user login  Never progress beyond this screen.