PVS 7.6: Upgrade Error "A system error as occurred error 0x00000103. No more data is available"
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Article ID: CTX212190
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Updated On:
Description
Performed an unattended upgrade from PVS 6.1 => PVS 7.6. Then when attempting to promote a version from Maintenance in the 7.6 farm the following error appears in the PVS Console: "Error: a system error as occurred error 0x00000103. No more data is available"
It doesn’t matter if the disk has the 7.6 target device software or 6.1 target device software the same error appears.
If OK is clicked, and then close the dialogue box and go back in, the access type has changed to the desired setting.
Resolution
Install "CfsDep2.inf" separately. To do that, execute the following command on the PVS Server.:
rundll32.exe setupapi,InstallHinfSection DefaultInstall 129 c:\Program Files\Citrix\Provisioning Services\drivers\cfsdep2.inf
Problem Cause
During an upgrade of PVS, the log file shows:
CA_LOGGING StartDriver – start
CA_LOGGING Service does not exist – cfsdep2
CA_LOGGING Install – end
You can check from windows CMD line or Powershell if the driver is missing:
driverquery /v | findstr /i citrix
Check if C:\Windows\system32\DRIVERS\CFsDep2.sys is on the list. Most likely it is missing.
Issue/Introduction
"Error: a system error as occurred error 0x00000103. No more data is available" appears in console when attempting to promote a disk, after upgrading PVS 6.1 => PVS 7.6.
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