COM Port Intermittently Inaccessible During ICA Sessions

COM Port Intermittently Inaccessible During ICA Sessions

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Article ID: CTX212090

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Description

We need to send some data to the serial com port of our thin client (IGEL). Many times a day, the com port is inaccessible.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To enable the fix, increase the default value of "MaxThreads" under the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\picaser\Parameters from 20 to a value greater than the number of COM port connections you want to support.

For example, if a XenApp server supports 100 sessions and each session opens two COM ports, the value of "MaxThreads" should be greater than 200.


Problem Cause

Max thread value was set to 20 

Issue/Introduction

We need to send some data to the serial com port of our thin client (IGEL). Many times a day, the com port is inaccessible.