Unable to Configure Scanner (TWAIN device) on XenApp7.6
book
Article ID: CTX211978
calendar_today
Updated On:
Description
Followed Citrix recommendations to configure Scanner on XenApp7.6, need assistance to achieve the same.
Resolution
WIA service was in a disabled state. Twain redirection policy not enabled. As per http://support.citrix.com/proddocs/topic/xenapp-xendesktop-76/xad-xaxd76-knownissues.html
"TWAIN redirection fails on hosted shared desktops and applications. This is a third party issue related to TWAIN applications that require TWAIN binaries to be located in certain paths. [#300854, 340999]
As a workaround, on your Windows Server 2012 machine running the VDA, copy these files to the following locations:
- Copy "twain_32.dll" to the "\WINDOWS" directory of the User profile (for example, copy twain_32.dll into the folder: "%USERPROFILE%\Windows\").
- Copy "twain_32.dll.mui" into the "\WINDOWS\en-US\" directory of the User profile (for example, copy twain_32.dll.mui into the folder: "%USERPROFILE%\Windows\en-US\").
"
Placed files in user profile, scanner worked fine.
Problem Cause
Policy/Service/Known issue
Issue/Introduction
Followed Citrix recommendations to configure Scanner on XenApp7.6, need assistance to achieve the same.
Additional Information
http://support.citrix.com/proddocs/topic/xenapp-xendesktop-76/xad-xaxd76-knownissues.html
Was this article helpful?
thumb_up
Yes
thumb_down
No