Getting error "Error = 80000004 in nsagg_process_stat_request , closing connection" in logs.

Getting error "Error = 80000004 in nsagg_process_stat_request , closing connection" in logs.

book

Article ID: CTX211892

calendar_today

Updated On:

Description

The below errors appear repeatedly in the ns.log file of Netscaler.

ns.log snapshot:

Apr 11 09:14:53 <local0.warn>netscaler [1114]: Error = 80000004 in nsagg_process_stat_request , closing connection
Apr 11 09:14:53 <local0.warn> netscaler [1114]: previous message repeated 0 times in last 300 seconds


 

Resolution

This is known Issue tracked under Issue ID 610809. Please upgrade to latest 11.1 or 11.0-65.35+ builds to get the fix for this issue.

Problem Cause

From Netscaler Release notes we can confirm the same under the Fixed Issues:

A warning error message "Error =80000004 in nsagg_process_stat_request, closing connection" displays when a nscollect module requests counter information from a nsagregator daemon at every 5 minute interval. The nsaggregator daemon prints the warning message as response to the request received from nscollect module for more than 256 counters.
[From Build 65.35] [# 610809, 577474, 579560]