User profile not getting deleted on log off

User profile not getting deleted on log off

book

Article ID: CTX210658

calendar_today

Updated On:

Description

User profile not getting deleted on log off. Duplicate profiles are being created on subsequent logins.

Similar to following error may get logged if TOSHIBA printer is mapped in HDX session
ERROR;;;;7264;DeleteAnyFile: Deleting the file <C:\*\TOSHIBA\eSTUDIOX\PSCRIPT\Cache\PluginCache\eSf6p\eSf6pdevicesettings\devicesettings.db> failed with: The process cannot access the file because it is being used by another process.
ERROR;;;;7264;DeleteAnyFile: Deleting the file <C:\* \TOSHIBA\eSTUDIOX\PSCRIPT\Cache\PluginCache\eSf6p\eSf6pdevicesettings\devicesettings.db> failed with: The process cannot access the file because it is being used by another process.

 
Administrator unable to delete the profile until Citrix Print Manager Service or Print Spooler service is stopped or restarted.
 

Resolution

  1. Reconfigure the exclusions for Profile Management to stop lingering process from hindering the deletion of the locally cached profiles.
  2. Use only Universal Printer Driver.
    Set policy Universal print driver usage with the value Use universal printing only.

Problem Cause

Some processes that are not excluded from UPM are lingering in session and holding up the deletion process of the locally cached profiles.
 

Issue/Introduction

The UPM profiles of end users are not not being deleted from the XenApp server session upon logoff.  Duplicate profiles are being created as a result and at times, end users receive temporary profile. 

Additional Information