Error: "Page Can't be displayed" When Connecting to StoreFront Through NetScaler Gateway

Error: "Page Can't be displayed" When Connecting to StoreFront Through NetScaler Gateway

book

Article ID: CTX210519

calendar_today

Updated On:

Description

The following error is displayed when connecting to StoreFront through NetScaler Gateway:
Page Can't be displayed

Resolution

Verify the IIS settings and if the Require SSL option is enabled on the IIS SSL settings then change it to ignore. After making this change, if you receive error "cannot complete your request" then change the domain name on the NetScaler Gateway session action to match the allowed domain in StoreFront.


Problem Cause

IIS site had Require SSL option enabled however NetScaler communicates with StoreFront is an unsecured way and it does not use a Certificate to trust the site.

Issue/Introduction

The following error is displayed when connecting to StoreFront through NetScaler Gateway: Page Can't be displayed