Error: "Error Id: XDDS:F05685F3" Connection To Existing License Server Fails After License Server Upgrade to 11.11.1 v2

Error: "Error Id: XDDS:F05685F3" Connection To Existing License Server Fails After License Server Upgrade to 11.11.1 v2

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Article ID: CTX210163

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Updated On:

Description

Connection to existing production license server XenDesktop 7.5 fails after License Server upgrade to 11.11.1.

  • New XenDesktop 7.5 environment.
  • Upgraded existing license server to 11.11.1 build 13017
  • Current XenApp 6.5 environment continued to function
  • New DDC is fails to connect to the license server with error:

Error Id: XDDS:F05685F3

Exception:

    Citrix.Console.Models.Exceptions.ScriptException An error has occurred with the Citrix License Server. Check the license server to make sure it is running, then try again.

       at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host)

       at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover)

       at Citrix.Console.PowerShellSdk.LicensingService.Scripts.GetLicenseUsageScript.RunScript()

       at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()

       at Citrix.Console.PowerShellSdk.LicensingService.PSLicenseService.GetLicenseInventory(String adminAddress)

       at Citrix.Console.Licensing.UI.Mmc.LicensingTabViewModel.<>c__DisplayClass5.<OnRefresh>b__0()

       at Citrix.Console.CommonControls.ViewModelBase.<>c__DisplayClassb.<RunBackgroundTask>b__9(Object s, DoWorkEventArgs e)

    

    DesktopStudio_ErrorId : UnknownError

    Sdk Error Message : UnknownError

    Sdk Error ID : Citrix.PowerShell.LicensingAdminStatus.UnknownError,Citrix.Licensing.Admin.SDK.Commands.GetLicInventoryCommand

    ErrorCategory : NotSpecified

    DesktopStudio_PowerShellHistory : GetLicenseUsageScript

    8/12/2014 5:08:52 PM

    

    Get-LicInventory  -AdminAddress 'https://dc002.cloudconnect.local:8083' -CertHash 'qo3w82/iEzB5wWZqw9/QAXoqJN/Z9MIzO4MA0CWDPJ1KRWRJiE1yMZiL+kY01DYs3XRt3QP4xY9FO5mKtgJmsw==' -CheckForSameSerialNumber

    Get-LicInventory : UnknownError

     + CategoryInfo : InvalidOperation: (Get-LicInventory:String) [Get-LicInventory], InvalidOperationException

     + FullyQualifiedErrorId : Citrix.PowerShell.LicensingAdminStatus.UnknownError,Citrix.Licensing.Admin.SDK.Commands.GetLicInventoryCommand

  

++++++++++++++ end ERROR ++++++++++

  • License Administration Console link from the DDC properly opens up the license server 
  • Windows Firewall policies set to disabled 
  • Amazon AWS and reside on the same security group which allows all communication between them. 
  • Results of the PowerShell command Get-ConfigSiteare correct
  • ran scout and submitted it to TaaS  - no relevent error reported.


Troubleshooting:
 

  • Engaged the License team
  • Licenses are OK
  • Check the Lic Svr install directory and noticed a folder missing :
  • LS folder was missing from this location:  C:\Program Files (x86)\Citrix\Licensing
  • Had Cx uninstall the license Server Software and reinstall
  • Reapplied the license file
  • Install Directory listed the LS folder
  • License server was able to be contacted by DDC
  • XD environment showed valid license with Get-BrokerSite

Resolution

Uninstalled and reinstalled license Server Software Re-applied the license file.

Problem Cause

  • LS folder was missing from this location:  C:\Program Files (x86)\Citrix\Licensing

Issue/Introduction

Connection to existing license server fails after License Server upgrade to 11.11.1. Error Id: XDDS:F05685F3.