Getting blank page in Internet explorer when password change for LDAP is prompted

Getting blank page in Internet explorer when password change for LDAP is prompted

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Article ID: CTX209636

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Description

Blank page in Internet Explorer when password change happens.

If we have Netscaler with customized Logon page, authentication includes username, password and rsa token.
When user's password expired and they get an popup asking for new password or a second rsa token, it works fine with Firefox and chrome browsers but brings up an empty grey popup window when using Internet Explorer 11.

Below is the error for reference

User-added image

When user adds it in Compatibility mode it works:

User-added image

Resolution

Replaced the file “resources.js” from "/var/netscaler/gui/vpn/“ (This folder should contain the latest files from that build)  and copy it over to the "/var/ns_guicustom/ns_gui/vpn” directory. This fixed the issue.

Also, if above doesn't fix the issue, t
he best way is to redo the customization on new build rather than porting over the customizations done on previous build before the upgrade.
 
Also please make sure we follow the below steps to do manual customization:
 
http://docs.citrix.com/en-us/netscaler-gateway/10-5/ng-connect-users-wrapper-con/ng-connect-users-cr-integration-con/ng-connect-custom-theme-page-tsk.html

Problem Cause

The issue is caused due to difference in Xpath support in IE11. The javascript issue <META http-equiv="X-UA-Compatible"content="IE=EmulateIE9"/> was fixed quite long back in 10.5 release but the customized files which the customer is using seems to be outdated and doesn’t have the fix