Unable to monitor Admin Partition with SNMP

Unable to monitor Admin Partition with SNMP

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Article ID: CTX209042

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Description

When we try to connect to the SNIP or VIP IP configured in the admin partition, the SNMP client gives an error that the SNMP service is unreachable.

Resolution

With the NetScaler firmware older than the below listed versions, this is working as per design. Because, the SNMP feature in admin partition is meant to configure an additional SNMP profile.
So, you can use a different community string and each partition can have a custom SNMP setting.

Even if you configure a custom SNMP profile on the admin partition, it will still operate on the IP address defined in the default partition.

The above design was worked under the Enhancement request - 609367 and modified with the below NetScaler Firmware Versions.

11.0-68.x and above
11.1-49.x and above

With this enhancement, the SNMP profiles have been modified to avoid dropping SNMP responses intended for non-default partitions. An SNMP agent can now track each SNMP request and send a response to a non-default partition.

Previously, if a non-default partition received an SNMP request through a subnet IP address, the SNMP agent on the partition responded to the default partition, because the SNIP address was defined on the default partition.

Problem Cause

The virtual IP or Subnet IP defined on Admin partition is not yet equipped of listening to SNMP requests and cannot send SNMP traps.
The SNMP functionality is only there in Admin Partition, so that its users can have their own set of community strings As they cannot access the default partition and hence cannot know the strings in SNMP configurations of default partition.

Issue/Introduction

Unable to monitor SNMP on Subnet IP created on the Admin Partition