Director Error "Cannot retrieve data. Data source unresponsive or reported an error".

Director Error "Cannot retrieve data. Data source unresponsive or reported an error".

book

Article ID: CTX208712

calendar_today

Updated On:

Description

The following error is seen in the event viewer of the Director server:

 
Log Name:      Application
Source:        Citrix Director Service
Date:          1/20/2017 11:05:33 AM
Event ID:      5
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      CtxDirector.RepLab.Local
Description:
The description for Event ID 5 from source Citrix Director Service cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
 
If the event originated on another computer, the display information had to be saved with the event.
 
The following information was included with the event:
 
Failed to connect to data source 'Unknown error.' ('http://CtxLicSrv.RepLab.Local/Citrix/Monitor/OData/v2').
 
Verify that the data source is available.
 
User: 'RepLab\CtxAdmin'
Console operation: 'Retrieving average logon duration details...'
 
Additional diagnostics information (error message):
'Monitoring Service'
 
the message resource is present but the message is not found in the string/message table
 
CDF traces will show HTTP 400 bad request

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve this issue, configure the following registry values on all the Controllers in the site and reboot.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters
Name: MaxTokenSize
Type: REG_DWORD
Data: 48000

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters
Name: MaxFieldLength
Type: REG_DWORD
Data: 48000

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters
Name: MaxRequestBytes
Type: REG_DWORD
Data: 12288000
 
 

Problem Cause

IIS returns the following error: “HTTP Error 400. The size of the request headers is too long”
The HTTP request contains the Kerberos token used for authentication, and the size of the token can vary depending on the number of AD groups the user account belongs to.


Dmc Service error Citrix.Dmc.Common.ConnectorException: Monitoring Service ---> Citrix.Dmc.Common.CommunicationException: Monitoring Service ---> System.Data.Services.Client.DataServiceQueryException: An error occurred while processing this request. ---> System.Data.Services.Client.DataServiceClientException: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>Bad Request</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD>
<BODY><h2>Bad Request - Request Too Long</h2>
<hr><p>HTTP Error 400. The size of the request headers is too long.</p>
</BODY></HTML>

Additional Information

https://support.microsoft.com/en-ie/help/2020943/-http-400---bad-request-request-header-too-long-error-in-internet-information-services-iis
https://support.microsoft.com/en-us/help/327825/problems-with-kerberos-authentication-when-a-user-belongs-to-many-groups