公開デスクトップ上で Internet Explorer を既定のブラウザに設定できない

公開デスクトップ上で Internet Explorer を既定のブラウザに設定できない

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Article ID: CTX208238

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Description

公開デスクトップ上で Internet Explorer をブラウザを既定のブラウザに設定した後、一旦ログオフして再度ログオンすると Internet Explorer が既定のブラウザではない状態にリセットされます。

Resolution

ホストからクライアントへのコンテンツリダイレクト機能を使用せず、Internet Explorer が既定のブラウザではない状態にリセットされることを防ぐためには、XenApp サーバー上で下記のレジストリの設定を行い、再起動を実施します。

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\SFTA
値の名前: DisableServerFTA
種類: DWORD
値のデータ: 1

※ 64 bit 環境の場合は上記のレジストリ キーは HKEY_LOCAL_MACHINE \Software\Wow6432Node\Citrix\SFTA になります。

なお、Internet Explorer が既定のブラウザでない状態にリセットされる動作は、コンテンツリダイレクト機能を使用するためにCitrix の iexplorer.exe (C:\Program Files\citrix\System32\iexplore.exe) が使用されることから発生する現時点の想定された動作となります。詳しくは下記の資料をご参照ください。

CTX133949
Server to Client Content Redirection Fails
http://support.citrix.com/article/CTX133949

Problem Cause

この現象はコンテンツリダイレクト機能が正しく動作するために必要な下記のレジストリ値の修正が、Hotfix Rollup Pack (HRP) 01 以降で行われていることによって発生します。

CTX133936
Server to Client Content Redirection Fails on Windows 2008 R2 with Internet Explorer
http://support.citrix.com/article/CTX133936

しかしながら、この現象は Citrixポリシー設定で[ホストからクライアントへのリダイレクト]設定が無効になっている場合 (デフォルトでは無効です) でも発生します。