"Cannot retrieve the data. View Director server event logs for further information." On Citrix Director

"Cannot retrieve the data. View Director server event logs for further information." On Citrix Director

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Article ID: CTX208206

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Updated On:

Description

This article applies to all 7.x versions of XenApp and XenDesktop. 

Citrix Director Reporting Wrong Data Or Not Updating

When launching Director, User Connection failure does not display any data instead a message is seen stating "Cannot retrieve the data. Data source unresponsive or reported an error. View Director server event logs for further information. "

Inside Director the below Event is displayed - Citrix Director Event ID 3- The data source 'Unknown error.'  responded with an unexpected error. Console operation: 'Retrieving connection failures by type details???' Additional information: ' (0)'

Resolution

Note: The solution to this issue has been implemented in XenDesktop 7.15 onwards.
For older versions follow the instructions below.
Back up data before making any changes and then follow these steps to check for zero values:

  1. Using SQL Management Studio console connect to XenApp/Xendestop Monitor database hosted on SQL server.
  2. Navigate to MonitorData.DesktopGroup
  3. Right-click this file and then choose "Select Top 1000 rows"
  4. When the query runs, check the Id field for any strings with '00000000-0000-0000-0000-000000000000' values.
    User-added image

If a record with id '00000000-0000-0000-0000-000000000000' exists, run the following command to delete it:

 
declare @did uniqueidentifier 
set @did = '00000000-0000-0000-0000-000000000000' 
delete from MonitorData.Session where machineid in (Select Id from MonitorData.Machine where DesktopGroupID = @did) 
delete from MonitorData.ResourceUtilizationSummary where DesktopGroupId = @did 
delete from MonitorData.ResourceUtilization where DesktopGroupId = @did 
delete from MonitorData.ApplicationInstanceSummary where DesktopGroupId = @did 
delete from MonitorData.DesktopGroupApplications where DesktopGroupId = @did 
delete from MonitorData.SessionActivitySummary where DesktopGroupId = @did 
delete from MonitorData.FailureLogSummary where DesktopGroupId = @did 
delete from MonitorData.ServerOSDesktopSummary where DesktopGroupId = @did 
delete from MonitorData.DesktopOSDesktopSummary where DesktopGroupId = @did 
delete from MonitorData.Machine where DesktopGroupId = @did 
delete from MonitorData.DesktopGroup where id = @did

 

Problem Cause

String of zeroes in MonitorData.machine and MonitorData.DesktopGroup table.

Issue/Introduction

When user logs into director "Cannot retrieve the data” is shown under user connection failures. Director Error: "Cannot retrieve the data. Data source unresponsive or reported an error. View Director server event logs for further information."