Error while opening file over network with AV scanning enabled

Error while opening file over network with AV scanning enabled

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Article ID: CTX208125

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Updated On:

Description

Users may encounter errors when trying to copy files from a local client to an ICA session (via Client Drive Mapping/CDM) when Anti-virus scanning is enabled. Opening files on the local client from an application in the ICA session also may fail.

Some of the errors noticed include:

"(File_Name) cannot be accessed. The file may be corrupted, located on a server that is not responding, or read-only."
"Invalid File Handle" Error

Depending on the Anti-virus vendor, the errors reported may vary. 
The symptom has been noticed with Sophos, Symantec, and McAfee.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Fix LA1855 was already on HRP06 (in fact this was included from HRP02 onwards) but it is not activated by default. 
The fix works only when the XenApp server has the below registry key present: 

1. Set the following registry key on the XenApp server: 
Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\picadm\Parameters 
Name: EnableSophosAVSupport 
Type: REG_DWORD 
Data: 1 

2. Reboot the XenApp server. 

Problem Cause

Antivirus is not able to scan files in CDM mapped drives

Issue/Introduction

Error while opening XLS file over network with Sophos AV scanning enabled. Opening ".xls" files from Client redirected drive on XenApp 6.5 HSD session throws error " cannot be accessed. The file may be corrupted, located on a server that is not responding, or read-only." with Sophos On Access Scanning enabled.