NetScaler Load Balancer Monitor for StoreFront Goes Down When 'Account Services' is Enabled on the Monitor

NetScaler Load Balancer Monitor for StoreFront Goes Down When 'Account Services' is Enabled on the Monitor

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Article ID: CTX207988

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Updated On:

Description

After upgrading StoreFront server to 3.5 (or implementing a new 3.5 server deployment), when monitoring with NetScaler (in an Load Balancer setup), the monitor goes down. This happens when "Account Services Check" is enabled on the monitor.

Resolution

Support for Unauthenticated Stores - In earlier releases, the StoreFront monitor tried to authenticate anonymous stores. As a result, a service could be marked as DOWN and you could not launch XenApp or XenDesktop by using the URL of the load balancing virtual server.
The probe order has changed. The monitor now determines the state of the StoreFront store by successively probing the account service, the discovery document, and then the authentication service, and skips authentication for anonymous stores.

Issue ID  - # 575549

This has been fixed in NetScaler v11.0 64.34


Problem Cause

NetScaler perl monitoring script for Storefront monitoring did not handle certain conditions when parsing responses from StoreFront 3.5

Issue/Introduction

After upgrading StoreFront server to 3.5 (or implementing a new 3.5 server deployment), when monitoring with NetScaler (in an Load Balancer setup), the monitor goes down. This happens when "Account Services Check" is enabled on the monitor, only.