Error: "HTTP 1.1 service unavailable" When Connecting to Unified Gateway

Error: "HTTP 1.1 service unavailable" When Connecting to Unified Gateway

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Article ID: CTX207952

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Updated On:

Description

When accessing the Unified Gateway logon page, after authentication the following error message is displayed:
"HTTP 1.1 service unavailable"

Resolution

Complete the following steps to troubleshoot this issue:

  1. Add the Storefront server as a service and test with different monitors to check the connectivity or port issue.The monitors like icmp , tcp-default can be used.

  2. ​Ensure that port 443 for StoreFront IP is allowed through the firewall.

  3. Ensure that there is no port/protocol (443) mismatch in Unified Gateway configuration under StoreFront settings.

  4. Add the expression HTTP.REQ.URL.PATH.SET_TEXT_MODE(IGNORECASE).STARTSWITH("/Citrix/STORE_NAME") to the content switch (Unified Gateway) policy if the expression is missing from the StoreFront store name.


Problem Cause

The issue can be caused due to many reasons. Some of the common reason of getting this error are:

a) Reachability issue from Netscaler to Storefront server.
b) Expression in the Content Switching Vserver is not correct, due to which it never hits the Gateway Vserver.

Issue/Introduction

When accessing the Unified Gateway logon page, after authentication the following error message is displayed: "HTTP 1.1 service unavailable"