book
Article ID: CTX207609
calendar_today
Updated On:
Description
Consider the following scenario:
Xendesktop 7.7 server VDA is installed on a server. This is uninstalled from add remove programs and the Desktop VDA is installed on the server with the /servervdi switch. The command ran was as follows:
Xendesktopvdasetup.exe /quiet /servervdi /components vda /controllers "FQDN of Controllers" /enable_hdx_ports /optimize /enable_remote_assistance /enable_real_time_transport
After the installation when an ICA session is made, you may see only a black screen and the Desktop is not shown. Console login to VDA and RDP session are successful.
Other symptoms include the following:
It may also be noticed that the session information shown in the DDC for this machine does not show the user name and shows only "-" instead. Also when the user logs off, the session state is set to Disconnected in Studio rather than session getting logged off. A reboot would be required to clear the user session.
Resolution
One of the main requirements for installing Workstation VDA on the server OS is that the Remote Desktop Service role should not be installed on the server (Ref:
http://docs.citrix.com/en-us/xenapp-and-xendesktop/7/cds-deliver-landing/cds-servervdi.html ). If it was installed, the following procedure would resolve the problem:
1. Uninstall the Remote Desktop Service role using the Remove roles and Features wizard from server manager.
2. Uninstall VDA from Add remove programs. Reboot the server.
3. Make sure that all the old VDA files have been removed from the disk. If program files\Citrix folder still contains folders related to VDA, rename/delete them.
4. Install VDA again with the required switches. For example,
VDAWorkstationSetup_7.7.exe /servervdi /components vda /controllers "Your controller FQDN" /enable_hdx_ports /optimize /enable_remote_assistance /enable_real_time_transport
Complete the install and reboot the server. This should resolve the black screen issue.
Problem Cause
RDS Role should be removed before installing VDA with /servervdi switch.
Issue/Introduction
After installing Desktop VDA with /servervdi switch on Windows 2012 Server OS, users get only a blackscreen when connecting through ICA.