Error: "Cannot start app 'App/Desktop Name'" on StoreFront 3.5

Error: "Cannot start app 'App/Desktop Name'" on StoreFront 3.5

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Article ID: CTX207588

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Updated On:

Description

After successfully upgrading to StoreFront 3.5, users are unable to launch applications or desktops with the following error:
Cannot start app "App/Desktop Name"

Cannot start app

Resolution

Complete the following steps to resolve this issue:

  1. Open the StoreFront MMC > Stores > Highlight Store > Manage Delivery Controllers.

  2. Under the Manage Delivery Controller window, confirm that there are no periods (.) or underscores (_) on any Display Name for any of the Delivery Controllers configured.
    To edit the display name select the Delivery Controller > Edit > modify the display name > OK.

  3. If you have more than one server in the group then propagate changes by going to StoreFront MMC > Server Group > Propagate Changes.


Problem Cause

There is a known issue with StoreFront 3.5 where, if there is period (.) or underscore (_) in the Display Name (Store > Highlight Store > Manage Delivery Controllers > Highlight Delivery Controller > Edit), users will see a "Cannot Start App" error.

Issue/Introduction

After successfully upgrading to StoreFront 3.5, users are unable to launch applications or desktops.