Storefront upgrade failing

Storefront upgrade failing

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Article ID: CTX207505

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Updated On:

Description

-In the event viewer windows application logs we get "\CitrixStoreFront-x64.msi failed with error code 1603"
-And in CitrixDeliveryServices logs we get " error in retrieving synchronization information "
-Checked logs on SF and see that it was unable to stop "Citrix Subscription Store" service.

Resolution

-As the installer stops all the services at the time we upgrade, the failure happens because of that.
-Try to stop the "Citrix Subscription Store" service manually. 
-If it fails to stop it, manually,restart the server once.
-After restarting the server this would work.
-Upgrade will also work.


Problem Cause

Unable to stop "Citrix Subscription Store" service.