Solution for the error "Windows cannot find C:\progra~1\citrix\secure access client\nsauto.exe"

Solution for the error "Windows cannot find C:\progra~1\citrix\secure access client\nsauto.exe"

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Article ID: CTX207344

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Description

Netscaler gateway plugin. After connecting to Netscaler VPN every time the user logged in the following message appears "Windows cannot find C:\progra~1\citrix\secure access client\nsauto.exe"
User gets logged on but gets the above mentioned error.

Resolution

Disable Windows auto login feature in Gateway profile.
Path:
Netscaler Gateway --> Policies --> Session --> Session Profiles (Select and edit the desired profile) --> Client Experience



By CLI you can run this command:
set vpn sessionaction <VPN profile name> -windowsAutoLogon OFF

Problem Cause

The entire path for the application nsauto.exe is C:\program files\citrix\secure access client\nsauto.exe

The plugin when accessing this location uses a shortcut name for.e.g 'progra~1' for 'program files'. There could be a problem with the shortcut name for 'secure access client' and hence the plugin is not able to find this file.






There is a microsoft document for this: https://technet.microsoft.com/en-us/library/cc959352.aspx