Some Citrix UPM Profile Do not Load Unless Recreated

Some Citrix UPM Profile Do not Load Unless Recreated

book

Article ID: CTX207153

calendar_today

Updated On:

Description

We have a Citrix XenDesktop 7.5 random pooled desktop step that utilizes Citrix Provisioning Services 7.5 and Citrix Profile Management. The virtualization platform is VMWare.

  • For Citrix UPM we have active write-back and profile streaming enabled.
  • Always cache is disabled.
  • Dont use personal vDisks.

Some users reported that the changes they made to their profiles are not sticking after they log off (such as Outlook signature changes), we did some testing and found that disabling Active Write-back resolved the issue. However, shortly after that some users started reporting that they are unable to logon to XenDesktop. When the users try to logon to the desktops, they get stuck on the welcome screen then the connection drops. The only way to allow the affected users to log back on is to rename their Citrix profile (effectively recreating it). In some situations, renaming the Pending folder only would allow them to log on. We enabled active-write back but the issue continue to happen regardless. What I noticed is that in the case of these users, the pending folder in their Citrix profile contains the changes from their last session. It seems for some reason, these changes are failing to merge with the primary profile creating this issue. Can you please assist us in finding the root cause for this issue and how to resolve it?

Resolution

Upgrade to UPM 5.4 to resolve this issue.
 

Problem Cause

From both the UPM log files, we see the same error - The user is getting  his profile as we see this information in logs:-
2016-02-08;11:41:45.509;INFORMATION;BREWLON;xentest1;1;1348;CopyFileWithRetries: Copied a file from: <\\srg-fsr-901\userprofiles$\xentest1\UPM_Profile\NTUSER.DAT> to <C:\Users\xentest1\NTUSER.DAT>.
There is no significance of any outlook file copied over during active session or during logoff.
 
There are few things that we would like to understand more on this:-
Ø  If we disable active write back, are there any files that are forced to copy during logoff? For that we have to disable active write back and test.
Ø  Create a new GPO(duplicate the original), disable active write back > Set it for test users only and try to replicate the issue.
Ø  If possible, Please get the files/folders copied over while making the changes in outlook profile.
Ø  The error pattern that we see here is also fixed in UPM 5.2.1. Instead of an upgrade to 5.2.1, I would recommend to upgrade to latest one i.e. 5.4.
From - http://support.citrix.com/article/CTX138198
Attempts by certain third party applications to rename or move files during logon or logoff might fail. For example, if there are files file0, file1, and file2 in the local profile, attempts to rename file2 to file3, file1 to file2, and file0 to file1 might fail during the logoff process if file2 already exists on the pending area or user store.
[#LC0465]