"This page can't be displayed. Turn on TLS 1.0 TLS 1.1, and TLS 1.2. in Advanced Settings And Try Connecting Again" While Accessing StoreFront
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Article ID: CTX206935
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Updated On:
Description
Error: "This page can't be displayed. Turn on TLS 1.0 TLS 1.1, and TLS 1.2. in Advanced Settings And Try Connecting Again" While Accessing StoreFront.

Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Follow article to enable TLS 1.0: How to restrict the use of certain cryptographic algorithms and protocols in Schannel.dll
Problem Cause
StoreFront 3.0.1 and earlier versions only support TLS 1.0. To resolve the issue, you have to enable TLS 1.0 on the registry on each of the StoreFront servers.
Issue/Introduction
If any Cipher suites have been modified in the registry manually or by any Windows Updates, and you are getting the message when accessing the Storefront page directly.
Additional Information
HTTP TLS error displays when selecting certain function in EPIC Hyperspace
In this case the application worked as expected on some XenApp servers. Open regedit and exporting...
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Cryptography\Configuration\Local\SSL\00010002
and importing into non-working XenApp server where HTTP error display resolves the issue.
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