Citrix Director Displays “Cannot Retrieve the Data” Under Policy and Session Details

Citrix Director Displays “Cannot Retrieve the Data” Under Policy and Session Details

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Article ID: CTX206472

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Updated On:

Description

Director shows “Cannot retrieve the data” under Policy and Session details and the below event is logged in the event viewer:

Event ID 6:An Unexpected error occurred 
Console Operation: 'Retrieving desktop policy details' 
Data at root level is invalid.LIne 1, position 1

The issue is reproducible with any browser.

Resolution

Following troubleshooting steps can be followed:

 
  • Rebuild the Performance counters by typing the following commands at a command prompt. Press ENTER after each command.cd\windows\system32lodctr /R

Reference: https://support.microsoft.com/en-in/help/2554336/how-to-manually-rebuild-performance-counters-for-windows-server-2008-6
 
  • Clear the Citrix Group Policy cache. The locally cached policies are located in the following locations on the VDA's (Delete the files and folders in each location but not the actual folder that contains them).
           C:\ProgramData\Citrix\GroupPolicy
           C:\ProgramData\CitrixCseCache
           C:\Windows\System32\GroupPolicy\Machine\Citrix\GroupPolicy
           C:\Windows\System32\GroupPolicy\User\Citrix\GroupPolicy\Rsop.gpf and C:\users\username\Citrix\GroupPolicy 


            Then run a gpupdate /force on the VDA.
  • Confirm from the registry HKLM\Software\Policies\Citrix 
    if the configured Citrix Policies are applied to the session.
  • Ensure that version of Citrix Group Policy Management console (GPMC) console installed on another server and Citrix Group policy client side extension (GPSCExt) installed on the VDA are on the same and latest version.
  • On the VDA/Session Host Server repair "Group Policy Client side Extension" and "Director VDA Plugin"
  • Reboot the VDA/Session Host Server when prompted.

            Installables can found at D:\x64\Virtual Desktop Components (Where D:\ is ISO Mount Drive)
           * CitrixCse_x64
           * DirectorVDAPlugin_x64
  • Disable Microsoft Group Policies applied from the domain if applied or put one of the VDA in an OU with No Microsoft GPO' applied in order to narrow down the issue and see if it still occurs.
  • Also Refer to the below link for more troubleshooting steps :

https://support.citrix.com/article/CTX220739

https://support.citrix.com/article/CTX134961

 

Problem Cause

This issue is generally seen due to Citrix Policies applied using Microsoft’s GPMC from the Domain Controller are either corrupt or not being updated.

This could also happen if Citrix GPO's are are not applying correctly or there are corrupt Citrix GPO's

Issue/Introduction

Citrix Director shows “Cannot retrieve the data” under Policy and Session details and event ID 6 "Retrieving desktop policy details" fails is seen on the event log of the server hosting director with the error “Data at the root level is invalid. Line 1, position 1."