Director not Showing the Licensing Status due to a Configuration Error

Director not Showing the Licensing Status due to a Configuration Error

book

Article ID: CTX206387

calendar_today

Updated On:

Description

Unable to view license status in XenDesktop Director with error "Cannot retrieve the data. Data source unresponsive due to a configuration error. View Director server event logs for further information. "

The event log on the Director server has the following error:

Log Name: Application
Source: Citrix Director Service
Event ID: 8
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: FQDN of Director server
Configuration is invalid.
Additional information: 'Could not establish secure channel for SSL/TLS with authority License server address:8083'.'
Event Xml: 8 2 0 0x80000000000000 68290 Application Director address 
Configuration is invalid.
Additional information: 'Could not establish secure channel for SSL/TLS with authority 'License server address:8083'.'



 

Resolution

  • Set up SSL Cipher Suite Order policy to default on Director and the License server, or, if needed, set up policy with same settings on both machines.
  • Policy is under: "Computer Configuration\Policies\Administrative Templates\Network\SSL Configuration Settings\SSL Cipher Suite Order"

Problem Cause

Misconfiguration of the SSL Cipher Suite Order causing issues communicating with the license server.

Issue/Introduction

Unnable to view license status in XenDesktop Director with error "Cannot retrieve the data. Data source unresponsive due to a configuration error. View Director server event logs for further information. "

Additional Information

Refer to Application Enumeration Failing after Applying Microsoft KB2919355 for Windows Server 2012 R2 or Citrix eDocs