Unable to Add XenDesktop Controller to Existing Site

Unable to Add XenDesktop Controller to Existing Site

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Article ID: CTX206375

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Updated On:

Description

We are in process of migrating our existing XenDesktop 7.6 controllers to latest OS i.e. Windows 2012, but getting some database related errors. Tried with SA privileges account with no avail. Environment: XenDesktop 7.6 OS Windows 2008 R2 & Windows 2012 R2.

Resolution

Give permissions for the Controller to access DB (user permissions on the server not the DB itself). Then Manually set all the connection strings. Stop all Services on controller, and start them one at the time while registering the services with database at the same time.



Do this for every Service separately. If it throws an error that means the service is already registered and simply reset the group membership then
 

Get-AcctServiceInstance | register-configserviceInstance

Get-AdminServiceInstance | register-configserviceInstance

Get-BrokerServiceInstance | register-configserviceInstance

Get-ConfigRegisteredServiceInstance | register-configserviceInstance

Get-ConfigServiceInstance | register-configserviceInstance

Get-EnvTestServiceInstance | register-configserviceInstance

Get-HypServiceInstance | register-configserviceInstance

Get-LogServiceInstance | register-configserviceInstance

Get-MonitorServiceInstance | register-configserviceInstance

Get-ProvServiceInstance | register-configserviceInstance

Get-SfServiceInstance | register-configserviceInstance

 

Reset group membership of all FMA services with configuration service:

 

 

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-AcctServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-AdminServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-BrokerServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-ConfigServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-EnvTestServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-HypServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-LogServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-MonitorServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-ProvServiceGroupMembership

Get-ConfigRegisteredServiceInstance -servicetype config | Reset-SfServiceGroupMembership


 

Problem Cause

The cause seems to be that our Services couldn’t properly register with the DB, because they were too busy communicating all the time. I believe this was cause by initial failure of joining the controller to the Site while the Machine didn't have permissions to access SQL server (High security bank environment).

Issue/Introduction

We are in process of migrating our existing XenDesktop 7.6 controllers to latest OS i.e. Windows 2012, but getting some database related errors. Tried with SA privileges account with no avail. Environment: XenDesktop 7.6 OS Windows 2008 R2 & Windows 2012 R2