Netscaler hangs during reboot requiring power cycle

Netscaler hangs during reboot requiring power cycle

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Article ID: CTX206246

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Updated On:

Description

  • Netscaler hangs during reboot and will not recover unless power is physically cycled (remove power cords)
  • LCD may display OUT OF SERVICE
  • Possible error messages in logs prior to reboot:  ipmi0: KCS error 01

 

Resolution

Upgrade to LOM version 3.x

Prerequisites:
  • Netscaler 9.3 / Build 65.8 or newer
  • Netscaler 10.1 / Build 123.9 or newer (MPX)
  • Netscaler SVM 10.1 / Build 129.11 or newer (SDX)
  • Netscaler 10.5 / Build 52.11 or newer
  • Netscaler 11.0
NOTE: Failure to meet these prerequisites will cause the Netscaler to erroneously report power supply failures.

Firmware upgrade procedures to upgrade from 2.x to 3.x firmware:
LOM Firmware download location   (be sure to select the proper firmware image for your hardware model)
Using a windows PC: CTX137970   (use the above-downloaded firmware in place of the BIN file in the IPMI_Firmware.ZIP file attached to the article)

NOTE: DO NOT attempt to upgrade from LOM firmware 2.x to 3.x using the LOM firmware GUI.  Failure to follow this warning may result in the Netscaler permanently refusing to boot and requiring an RMA to resolve.
 

Problem Cause

LOM firmware 2.x can cause the Netscaler to hang during reboots.