Error: "The Session Recording Player Cannot Play Back This File"

Error: "The Session Recording Player Cannot Play Back This File"

book

Article ID: CTX206145

calendar_today

Updated On:

Description

You receive the following error message (shown below) when attempting to review certain recordings using the Session Recording Player.

User-added image

"The Session Recording Player is unable to play back this file because it was recorded using version <version_number> of the Citrix Client for Windows. This player only supports up to version <version_number>.

 Please upgrade your Session Recording Player to support the latest version of the Citrix Client for Windows."

Resolution

Use the following procedure to correct the issue:

  1. Determine the client build used by the accessing computer during the recording. Do not rely on the session information pane in the Session Recording Player for this information. It does not provide accurate information on client build number until you have completed all of these steps. You can use the error message given in the player, or the information in Director for XenApp/XenDesktop.
    User-added image

  2. On each installation of the Session Recording Player, locate the SsRecPlayer.exe.config file. It is found in InstallationPath\player\bin folder. As a precaution, make a backup copy of this file.

  3. Open the SsRecPlayer.exe.config file in Notepad. Look for the following entry:
     <add key=”Windows” value=”xx.xxx.xxxx” 
    where xx.xxx.xxxx specifies the current highest version supported for playback).

  4. Replace the version number found in step 3 with the latest build version, as determined in step 2.

  5. Save the file. If you changed to the Word Wrap feature in Notepad, turn it off before saving the file.


Problem Cause

This issue occurs if the client computer used in the recorded session has a newer Receiver or recently upgraded to a new Receiver.

Issue/Introduction

Error: "The Session Recording Player Cannot Play Back This File"