NetScaler Load Balancing Exchange 2013 is Slow
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Article ID: CTX205937
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Updated On:
Description
Accessing Exchange 2013 via NetScaler is significantly slower than going directly to backend servers. There are timeouts and latency reported.
Resolution
Primary Recommendation:
- Disable surge protection on all related Exchange services/service groups. Services > Settings > Surge Protection = Disabled/OFF
Other Recommendations:
- Ensure source IP persistence is enabled for all related Exchange Vservers with a timeout value of more than 2 minutes. (60 minutes or 120 minutes)
- Internal Vserver - Change source IP persistence timeout value from 2 minutes to 60 minutes/120 minutes
- External Vserver - Enable source IP persistence and change timeout value to 60 minutes/120 minutes
- Increase client idle timeout on related Exchange Vservers from 180 seconds to at least 1800 seconds. (1800/3000 should be fine). (Vserver > Traffic Settings > Client Idle Timeout)
- Increase client and server idle timeouts on services from 180/360 to 1800 or 3000 seconds. (Service > Thresholds and Timeouts)
Problem Cause
Surge Protection was enabled on the service causing Surge Queue build-up on the Exchange services. Disabling surge protection fixed the issue.
Issue/Introduction
Accessing Exchange 2013 via NetScaler is significantly slower than going directly to backend servers. There are timeouts and latency reported.
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