Desktop Delivery Controller is Unable to Communicate with the License Server in XenApp 7.7

Desktop Delivery Controller is Unable to Communicate with the License Server in XenApp 7.7

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Article ID: CTX205238

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Updated On:

Description

XenApp 7.7 and XenDesktop 7.7: Delivery Controller is unable to communicate with the License Server.

Resolution

Complete the following steps:

  1. On the Delivery Controller, right click Start and select Computer > Properties > Advanced system settings > Environment Variables (under System).

  2. Configure the environment variable FLEXLM_TIMEOUT with value 900000.

  3. Reboot the Delivery Controller machine.


Problem Cause

It seems to happen due to latency or network conditions as the licensing client on the broker is not able to contact the License server due to a connection timeout.

Issue/Introduction

Desktop Delivery Controller is Unable to Communicate with the License Server in XenApp 7.7.

Additional Information

  • Ping, telnet to port 27000 works when connecting to the License Server from a non-working Delivery Controller.

  • Telnet to port 8082, 8083 works from non-working Delivery Controller to Licenses Server

  • If you run the following command on the Controller:


    Test-BrokerLicenseServer

    This information is returned:
           Result: Inaccessible
  • A CDF Trace shows the following output in the Non-working Scenario :

Test-BrokerLicenseServer  -AdminAddress "DDC:80" -ComputerName "LicenseServer" -Port 27000",""
Xendesktop Management Console,_#dotNet#_,0,,9,CDF_NET_INFO,"CmdletExecutionLog(1128): Script TestLicenseServerLocationScript(1125): [RES] Inaccessible",""