Change Password Option Not Working for Users Connecting to StoreFront

Change Password Option Not Working for Users Connecting to StoreFront

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Article ID: CTX205141

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Updated On:

Description

Users are able to log into StoreFront 2.5 successfully, but are unable to change passwords. Once a user clicks the change password menu option, they get error: Cannot complete your request. The user is then presented with a logon button.

  • Event logs do not indicate issue.
  • The StoreFront 2.5 configuration to allow password changes in enabled.

Resolution

Customer was using a Load Balancing vserver to load balance StoreFront server. The Load Balanced vserver was set to use source IP persistency. On the services bound to the load balance vserver the ClientIP Header value of "X-Forwarded-For" was missing. We set this value and now users are able to change password with storefront without an issue.


Problem Cause

The issue was related to using a Load Balance vserver to load balanced StoreFront and not applying the Client IP Header value "X-Forwarded-For" 
To set this value open the Load Balancing service node -->advanced tab-->Settings. Enable the Client IP Header option and within the value box enter X-Forwarded-For.

Issue/Introduction

This article gives information about the issue where password change is not working correctly when Storefront servers are load balanced on Netscaler.

Additional Information

More information regarding Client IP header can be found below:

http://docs.citrix.com/en-us/netscaler/11/traffic-management/load-balancing/load-balancing-advanced-settings/insert-cip-in-request-hdr.html