Error: "Failed To Launch Application.. " Published Application Internet Explorer Not Working In XenApp 7.6 FP3

Error: "Failed To Launch Application.. " Published Application Internet Explorer Not Working In XenApp 7.6 FP3

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Article ID: CTX205117

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Updated On:

Description

After installing FP3 on all the VDAs published shared folders stopped working. The following error in the application log on the VDA server: Failed to launch application "Application Name" with command line '"C:\Program Files (x86)\Internet Explorer\iexplore.exe (Path to user profile folder)"' on client 'Client Machine' for domain/user 'domain\username' in session '2'. Ensure that the application is installed and that the user has permission to launch it.

Resolution

Removed the parameter from the application location section and added it to the parameter (optional) section and the issue was resolved.

Non-Working
User-added image
If the application is published with the command line argument set as displayed above, the application will not launch and produce the error if it is an existing application previous to FP3. If publishing new while on FP3 a "Length of parameter exceeded" message will pop up not allowing you to publish the application. 

Working
User-added image
Setting it in this manner will allow you to publish and properly launch. 

Problem Cause

XenApp with FP3 was not allowing the command line argument to be in the same place where the path to the executable file to the application was being set. 

Issue/Introduction

In this article explains how to fix an issue when a customer upgrades to FP3 and is unable to launch applications with command line arguments.