NetScaler newnslog Files Not Compressed Which Results in /var Directory Getting Full

NetScaler newnslog Files Not Compressed Which Results in /var Directory Getting Full

book

Article ID: CTX205014

calendar_today

Updated On:

Description

The newnslog file does not get compressed which leads NetScaler appliance to run out of disk space (/var gets full).

Resolution

Solution 1

1. Look for nslog.nextzip file in the /var/nslog/ and check if it is empty and does not have any number in it. For example:​
root@my-vpx# cd /var/nslog/
root@my-vpx# cat nslog.nextzip
root@my-vpx#
Notice the output of above command does not display any output.
The following is an example from a NetScaler without this issue where we see the output (88):
root@my-vpx# cd /var/nslog/
root@my-vpx# cat nslog.nextzip
88

2. If the nslog.nextzip is empty and does not have any number listed then complete the following steps to resolve this issue:

Log on to NetScaler CLI and go to shell prompt and run the following commands:

root@my-vpx# cd /var/nslog/
root@my-vpx# cat nslog.nextfile
88

Note the output number of the above command, which will be used later in this article. The output of this command in this case is 88.

3. Execute the following:

cat nslog.nextzip
  If nslog.nextzip does not have any number in it, then you need to subtract 2 from the nslog.nextfile value. For example: 88 – 2 = 86.
echo 86 > nslog.nextzip
Go to /var/nslog and confirm if the newnslog files are getting compressed now.
Note: This procedure will not compress the already uncompressed files; it will only start compressing new files.

Solution 2

  1. Log on to NetScaler CLI and switch to shell prompt, open the crontab file in vi using the following command:

    vi /etc/crontab
  2. Do not make any changes to crontab file, save and quit using the following command:
    wq! 
  3. Verify if the timestamp for the crontab file has been update in the directory using the following command:
    ls –lh

Problem Cause

Issue is caused due to no value in nslog.nextzip file.

Issue/Introduction

The newnslog file does not get compressed which leads NetScaler appliance to runs out of disk space (/var gets full).

Additional Information

CTX133588 - How to Free Space From /var Directory of NetScaler Appliance When Unable to Log on to NetScaler GUI